What Even Is A Protocol Anyway?
Using Wireshark for the activities in the CST module presented me with loads of acronyms I had seen before, but didn’t really understand how they work. We all know about HTTP, hypertext transfer protocol, and IP, internet protocol, and have some vague idea about what they are, however, how do they work? What even is a protocol anyway?
The video below gives a fantastic explanation of protocols, and a quick overview of Wireshark.
Just like with our ISO/IEC 27001 and other standards documents, there are rules to follow about implementing processes. The Internet Engineering Task Force publishes standards documents for networking protocols, which essentially is a list of rules about how they function.
A protocol is essentially an established way of doing something: an agreement or etiquette between two entities about how to perform a task.
There are three main types of network protocols:
- communication – used to make sure that data can be transmitted securely from one point to another in its entirety
- management – protocols that manage administration on your network so you can program devices to transmit data as expected
- security – protects network resources from hackers and safeguards data
Below are common protocols you may have come across, and their relevant standards document (known as a RFC, or Request For Comment):
- Transmission Control Protocol (TCP) RFC 9293 aka STD 7
- Internet Protocol (IP) RFC 791 part of STD5
- Internet Control Message Protocol (ICMP) RFC 792 part of STD 5
- User Datagram Protocol (UDP) RFC 768 / STD 6
- File Transfer Protocol (FTP) RFC 3659
- Hypertext Transfer Protocol (HTTP) RFC 9110 aka STD 97
- Simple Network Management Protocol (SNMP) RFC 1157
- Post Office Protocol (POP) RFC 1939
- IPSec RFC 4301
- Transport Layer Security (TLS) RFC 8446
A list of all IETF Standards can be seen here: https://datatracker.ietf.org/doc/std
References
A deep dive into network security protocols: Safeguarding digital infrastructure 2024